Sphider 3-MB (multi-byte) fork

Announcements concerning the forum
Post Reply
User avatar
captquirk
Site Admin
Posts: 113
Joined: Sun Apr 09, 2017 8:49 pm
Location: Arizona, USA
Contact:

Sphider 3-MB (multi-byte) fork

Post by captquirk » Sat Apr 20, 2019 1:39 am

The regular edition of Sphider (currently at 2.4.0) will continue to be maintained with periodic improvements. The 2.4.x series is being ported to a new fork, Sphider 3-MB.

Sphider 3-MB will replace all standard string operations with multi-byte string (mbstring) operations. This will ensure proper handling of multi-byte unicode characters. The fork is necessary because not all PHP installations have the mbstring extension installed!

Sphider 3-MB does have certain operational requirements.
1. MySQL server (SERVER, not client) must be AT LEAST 5.5.3, with 5.6 or greater recommended. A MariaDB equivalent is okay.
2. PHP must be AT MINIMUM 5.4. PHP 7+ is recommended.
3. The MySQLnd module MUST BE installed and usable.
4. The mbstring extension MUST be installed and usable.

Sphider 3-MB will be available approximately May 1, give or take a couple days.

Post Reply