Not getting page descriptions, only meta desc in text preview (1.5.3)

Come here for help or to post comments on Sphider
Post Reply
fatwreck
Posts: 3
Joined: Mon Apr 17, 2017 9:22 pm

Not getting page descriptions, only meta desc in text preview (1.5.3)

Post by fatwreck » Wed Apr 19, 2017 5:29 pm

Hi! This is great. Long story short, client asked for search on Concrete5.8 site. Did it and found it didn't index Express objects. Weird, then you come in with a new version of Sphider. Alright!

Tested Sphider stand alone, indexed site, everything good. Challenge come in when adding it to a Concrete5.8 site. Made a few changes and working smooth. I've styled it and last thing left is to get the page text preview to show.

Right now it only shows the Meta tag description. I had to make many of the $variables global for Sphider to work on the Concrete5.8 site, but the description isn't displaying.

One theory is that the description requires a bundle of variables to become global for it to display. So far I've peppered in

Code: Select all

global $fulltxt, $begin_pos, $desc_length;
where I thought appropriate. Very scientific of me. This got the Meta description showing, but not the page snippet.

Any ideas?

User avatar
captquirk
Site Admin
Posts: 97
Joined: Sun Apr 09, 2017 8:49 pm
Location: Arizona, USA
Contact:

Re: Not getting page descriptions, only meta desc in text preview (1.5.3)

Post by captquirk » Thu Apr 20, 2017 3:16 am

The length of page descriptions is controlled by a setting on the settings tab of the admin panel, in the "Search Settings" section. By default, "Maximum length of page summary displayed in search results" is set to 250.

There was a problem with version 1.5.1.1 (PDO) in which ANY change to the Sphider settings caused the description length to be either 0 or 1. :oops: Later versions corrected the problem. However, if upgrading, the problem was fixed but the setting was not restored. Regardless, you may want to check that to be sure the description length is not 0. A related setting a few lines above the description length, ("The length of the description string queried from the database when displaying search results.") has a default of 0 (meaning unlimited) and if it is set to a very low number greater than zero, there may not be much in the way of a description.

Short answer, check you settings to be sure the query length is a decent number, or preferably, 0. Then check the description length to be sure it is not 0. The default is 250. If these values are correct, or resetting them to proper values does not correct the problem, check back and we can look at a couple other things to troubleshoot.

And congrats on being the first customer to the NEW Sphider help forum! :D

fatwreck
Posts: 3
Joined: Mon Apr 17, 2017 9:22 pm

Re: Not getting page descriptions, only meta desc in text preview (1.5.3)

Post by fatwreck » Mon Apr 24, 2017 11:25 pm

Thanks, this new version of Sphider saved my bacon.

I eventually figured it out by playing with the settings and adding global variables all over the place. Not sure what the kicker was but it's working now. Sorry for not being more specific since I did this last week sometime.

User avatar
captquirk
Site Admin
Posts: 97
Joined: Sun Apr 09, 2017 8:49 pm
Location: Arizona, USA
Contact:

Re: Not getting page descriptions, only meta desc in text preview (1.5.3)

Post by captquirk » Tue Apr 25, 2017 2:29 pm

It's all working? And I had such great ideas for troubleshooting the problem! :lol:

Seriously, that is great. I'm glad it is all working out for you and even happier that 1.5.3 can fill your needs. Spread the word and feel free to come back with any other issue you may have.

fatwreck
Posts: 3
Joined: Mon Apr 17, 2017 9:22 pm

Re: Not getting page descriptions, only meta desc in text preview (1.5.3)

Post by fatwreck » Wed Apr 26, 2017 7:32 pm

You got it.

Post Reply