Problem with installing 1.5.3 and 1.5.4 versions

Come here for help or to post comments on Sphider
Post Reply
User avatar
captquirk
Site Admin
Posts: 122
Joined: Sun Apr 09, 2017 8:49 pm
Location: Arizona, USA
Contact:

Problem with installing 1.5.3 and 1.5.4 versions

Post by captquirk » Mon Jun 12, 2017 4:26 pm

It seems the database has not been updating correctly when running update_rollup.php in the 1.5.3 and 1.5.4 versions (including PDO versions).
You can check if you are affected by looking at the Settings tab in Sphider. If this indicates 1.5.2 and you know you have upgraded to 1.5.3 or 1.5.4, you are affected.

For 1.5.3 users, this is not a big deal. For 1.5.4, it is a big deal, as a column is now missing in the settings table. The Downloads page of the Worldspaceflight forum has a fixed version of update_rollup.php, but you can fix the problem yourself.

Edit update_rollup.php. Towards the bottom you will see a series of lines with "case nn:". For 1.5.3 versions, remove the line "break;" in the "case 5:". For 1.5.4 versions, remove the line "break;" from BOTH "case 5:" and "case 6:".

Re-run update_rollup.php. Check the settings tab to ensure it now says 1.5.4.

**************************************************************
SPECIFICS
Edit update_rollup.php and re-run; Edits are as follows -
For Sphider 1.5.3:
switch ($state) {
case 1:
update141();
case 2:
update142();
case 3:
update150();
case 4:
update151();
case 5:
update152();
break; REMOVE THIS LINE
case 6:
update153();
break;
case 99;


For Sphider 1.5.3 PDO:
switch ($state) {
case 1:
update141();
case 2:
update142();
case 3:
update150();
case 4:
update1511();
case 5:
update1521();
break; REMOVE THIS LINE
case 6:
update1531();
break;
case 99;


For Sphider 1.5.4:
switch ($state) {
case 1:
update141();
case 2:
update142();
case 3:
update150();
case 4:
update151();
case 5:
update152();
break; REMOVE THIS LINE
case 6:
update153();
break; REMOVE THIS LINE
case 7:
update154();
break;
case 99;


For Sphider 1.5.4 PDO:
switch ($state) {
case 1:
update141();
case 2:
update142();
case 3:
update150();
case 4:
update1511();
case 5:
update1521();
break; REMOVE THIS LINE
case 6:
update1531();
break; REMOVE THIS LINE
case 7:
update1541();
break;
case 99;

Griffie
Posts: 1
Joined: Fri Aug 18, 2017 12:51 pm

Re: Problem with installing 1.5.3 and 1.5.4 versions

Post by Griffie » Thu Aug 24, 2017 8:39 am

Thankyou captquirk, I got 1.5.4 installed now!

Post Reply