Trouble installing

Come here for help or to post comments on Sphider
Post Reply
perdittmann
Posts: 1
Joined: Fri Jul 30, 2021 7:42 am

Trouble installing

Post by perdittmann »

Hopefully someone can help me, I am out if ideas.

I am trying to set up a new installation on a shared server running PHP 5.6.4, and after successfully running the install.php script (the database gets filled) I head over to admin.php and get a blank page.
Turning on error reporting (admin.php, line 17/18) does not change anything, "debugging by hand" (inserting an echo command after each line to find out where excecution breaks) leads me to suspect that the line

Code: Select all

17	$result = $stmt->get_result();
in settings/conf.php is where something goes wrong.

Is there someone out there who can make sense of that?
Any help would be appreciated. Thanks in advance!
Per
User avatar
captquirk
Site Admin
Posts: 168
Joined: Sun Apr 09, 2017 8:49 pm
Location: Arizona, USA
Contact:

Re: Trouble installing

Post by captquirk »

Create a PHP script. Although the name doesn't really matter, I suggest "info.php." It will contain the following code:

Code: Select all

<?php
phpinfo();
?>
Load this to your server and run it from a browser. It will provide details on your PHP installation. Scroll down through the list of installed PHP modules, looking for "mysqli" and "mysqlnd". Both of these are required to run Sphider.

If these modules are not present, you should be able to install them as PHP 5.6.4 does support them.

If they do indeed exist, then download and run the "mysqlnd_check_tool" from the Sphider download page to be sure it is working properly.
Post Reply